Comment configurer deux réseaux locaux ?

Network

Je me tâte entre se faire de l’intro et entrer directement dans le vif du sujet. Mais bon, une petite intro vite fait sera pas désagréable.

Aujourd’hui je vais te montrer comment configurer deux réseaux locaux interconnectés. Au fait, un réseau local ! tu sais ce que c’est, hein ? Indice : ça s’abrège par L.A.N, qui veut dire en anglais Local Area Network.

Selon les trois types des réseaux suivant leur étendue, le LAN est le plus petit, parce qu’il est de la taille d’un site dans une seule entreprise.

En ce qui me concerne, mon entreprise a deux sites distants, et chaque site a un LAN. Le hic c’est : comment interconnecter ces deux sites distant ? et ben, en les configurant évidement va.

Navré de t’avoir fait attendre, je vais entrer dans le vif du sujet maintenant.

Dans la première partie, je vais utiliser un simulateur, et dans la deuxième, un émulateur.

Côté logiciel, le simulateur sera le Cisco Packet Tracer et l’émulateur sera le GNS3. Je te parlerai de la différence entre les deux prochainement.

Première partie : Configuration avec le simulateur

Tu peux rapidement télécharger la dernière version du Cisco Packet Tracer ici, si bien-sûr tu l’as pas encore. Par contre, si tu l’as déjà, je peux passer directement aux configurations.

Paré ? alors c’est parti…….

Etape 1 : L’architecture du réseau.

Tu vois l’image ci-dessous ? c’est ça l’architecture que je vais utiliser pour la configuration, j’espère qui tu as réussi à la reproduire toi aussi.

image 1a

T’inquiètes si c’est pas exactement comme c’est chez moi, l’important c’est de suivre la même logique.

Si tu veux que le label de port soit visible, afin de te repairer facilement, tu peux changer en cliquant sur __Options -----> Preferences ------> tu coches la case Always Show Ports Labels In Logical Workspace.

image 1b

Etape 2 : Table d’adressage.

Tu connais surement déjà le rôle que joue une adresse IP dans un réseau. Je me permets de me passer des ces détails.

C-dessous tu peux voir la tableau des adresses que je vais utiliser pour la configuration, tu peux adapter selon la classe que tu choisiras, surtout, n'oublies pas respecter la logique.

image 1c

Etape 3 : Attribution d’adresses aux PC.

L’attribution des adresses IP se fait manuellement pour les PC, voici comment le faire rapidement , tu cliques sur PC -----> Desktop -----> IP Configuration, à partir d'ici, tu peux attribuer l’adresse à ton PC.

image 1d

Sur l'image ci-dessus, tu peux bien voir que j'ai j’attribué l’adresse IP au PC0 du LAN 1, exactement comme celle dans la table d’adressage.

Dans la table d’adressage, j’ai utilisé le masque de sous réseau CIDR /24 pour gagner de l’espace. Mais sur le PC, le masque de sous réseau doit être en décimal, d’où le 255.255.255.0 à la place du /24.

Le PC doit avoir comme passerelle l’adresse IP du routeur, pour communiquer avec ce dernier, donc, les deux PC du LAN 1 auront comme passerelle l’IP du Router0 et ceux du LAN 2 celle Router1

Etape 4 : Configuration des Routeurs.

Je commence avec le Router0 du LAN 1, je suppose que les interfaces ne te compliqueront pas.

Routeur 0

Pour le configurer, il faut cliquer sur le Routeur, puis sur CLI. A la question Would you like to enter the initial configuration dialog? [yes/no]: , répondre par No.

image 1e

A partir d’ici, je peux commencer à configurer le Routeur.

Router>enable
Router#configure terminal
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0

Ces commandes ont aidé surtout à attribuer l'adresse IP au routeur.

image 1f

Router(config-if)#no shutdown

image 1ff

En entrant la commande no shutdown sur l’interface f0/0, elle vire au vert, pour montrer qu’elle est maintenant ouverte.

image 1g

En essayant de faire un ping du PC1 vers le Router0, tu peux voir que les deux équipements communiquent bel et bien, c'est dit au fait que çà se trouve sur le même LAN.

image 1h

Maintenant je veux configurer l’adresse IP de l’interface du Point à Point, celle qui interconnecte les deux routeurs.

Router#configure terminal
Router(config)#interface f0/1
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown

image 1j

Voilà, c’est fini pour le moment avec la configuration du Router0 pour le LAN 1. Je peux passer maintenant au Router1 du LAN 2.

Routeur 1

Router>enable
Router#configure terminal
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown

image 1k

Une fois la commande no shutdown entrée tu peux voir qu’ici aussi, l’interface vire au vert.

image 1l

Le ping entre le PC2 et le Router1 passe aussi, c’est qui est logique parce que c’est dans le même réseau local.

image 1m

Il me reste qu’à configurer encore une fois l’interface d Point à Point, sur le Router1.

Router#configure terminal
Router(config)#interface f0/1
Router(config-if)#ip address 10.0.0.2 255.0.0.0
Router(config-if)#no shutdown

image 1n

Dès que la commande no shutdown est entrée sur le deuxième routeur, les deux interfaces s’ouvrent.

image 1o

Malgré ça, si tu essayais de faire un ping du LAN 1 vers le LAN 2 , jamais jamais cela ne passera ! tu sais pourquoi ? Parce qu’il reste la dernière étape la plus importance, le routage.

Etape 5 : Le routage.

Il y a deux types des routages, statique et dynamique. Le routage statique est recommandé sur le réseau de petite taille, ça se fait sans aucun protocole de routage.

Le routage dynamique est recommandé sur le réseau de grande taille, ça se fait à l’aide des protocoles de routage.

Dans cet article, comme c’est un réseau de petite taille, le choix est clair.

Puisque je vais utiliser le routage statique, j’dois te faire savoir que, j’aurai besoin d’une seule commande pour configurer la route, marrant hein ?

Ce routage se fera en suivant le chiasme ! euh oui, le seul chiasme du figure de style. En gros, les adresses du premier routeur seront configurées sur le deuxième routeur, et celles du deuxième routeur sur le premier.

La syntaxe c’est comme suite : ip route suivi de l’adresse réseau du routeur voisin suivi du masque de sous réseau suivi de l’adresse IP du point à point du routeur voisin.

C’est aussi simple que ça ! voyons voir ce que ça donne concrètement.

Routeur 0

Router(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.2

image 1p

Routeur 1

Router(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1

image 1q

Etape 6 : Test

Je vais faire un ping du PC0 dans le LAN 1 vers le PC2 dans le LAN 2, l’objectif était de faire communiquer les deux réseaux locaux.

image 1r

En faisant un show ip route sur le Router0, tu peux voir la route créée.

image 1ss

Deuxième partie : Configuration avec l'émulateur

Au début, je me suis dit que j’allais faire les dans un même article, mais arrivé la fin de celui-ci, j’ai constaté que ça sera beaucoup trop long, et donc déconcentrant.

Alors j’ai jugé bon de parler de la configuration avec l’émulateur GNS3 à part. Tu peux cliquer ICI pour lire l’article.

Conclusion

Tout ce que je souhaite c’est que cet article t’ait été utile et que tu aies trouvé une deux ou trois réponses à tes questions.

Je suis conscient que je pas fait exactement ce que j’ai dit mais, le prochain article parlera de la partie que j’ai zappé ici.

Tout ce que j’peux dire c’est, à bientôt ! n’oublies pas de partager surtout.

PS : Restes connecté pour pas louper la suite. Arigato !