Comment configurer deux réseaux locaux avec GNS3 ?

Network

Contrairement à Cisco Packet Tracer qui est un simulateur, GNS3 lui c’est un émulateur.

La différence être les deux est que, GNS3 combine les périphériques virtuels et physiques afin que la simulation aussi complexe soit-elle, puisse bien se faire.

Alors qu’avec Cisco Packet tracer lui, il peut faire que la simulation avec les périphériques virtuels seulement.

Aujourd’hui , je vais parler de la configurer deux réseaux locaux avec GNS3, comme suite dans la première partie sur la configuration avec Cisco Packet Tracer.

Tu peux télécharger la dernière version du GNS3 ici.

Sans compter la conclusion, je vais te montrer en six étapes comment faire. je commence directe avec la première.

Etape 1 : L’architecture du réseau.

Le routeur à gauche constitue le premier LAN, et le routeur à droite le deuxième LAN.

pic00

Etape 2 : Table d’adressage.

Je vais utiliser la même table d’adresse que sur la configuration avec Cisco, dont tu peux trouver l’article ICI, la seule différence sera les noms des périphériques.

pic01

Avant de commencer n’importe que configuration, il faut d’abord cliquer sur le bouton Start, pour démarrer les équipements.

pic0000

Une fois que tu cliques sur le bouton Start, toutes les interfaces deviendront verte, comme le montre l’image ci-dessous.

pic000

Etape 3 : Attribution d’adresses aux PC.

Avec la dernière version de GNS3 que tu peux télécharger ici, l’attribution d’adresses IP se fait sur le CMD, contrairement sur Cisco.

Pour attribuer l’adresse, tu dois faire clique droite sur le PC puis tu, cliques sur l’option Console.

Dans la console, tu dois entrer la syntaxe dont l’ordre est la suivante : adresse IP suivie du masque de sous réseau en CIDR suivi de la passerelle.

PC1 du premier LAN

PC1> ip 192.168.1.2/24 192.168.1.1

Après avoir attribué l’adresse avec cette syntaxe, tu auras le message suivant, qui montre qu’une adresse a bel et bien été attribué au PC

PC1 : 192.168.1.2 255.255.255.0 gateway 192.168.1.1

pic02

PC3 du deuxième LAN

PC3> ip 192.168.2.2/24 192.168.2.1
PC1 : 192.168.2.2 255.255.255.0 gateway 192.168.2.1

pic002

Etape 4 : Configuration des Routeurs.

Routeur 1

Le routeur 1 c’est celui du premier LAN.

Première Interface

R1#configure terminal
R1(config)#interface f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

Le bouton Start permet de démarrer l’équipement, alors que la commende No Shutdown permet d’ouvrir l’interface, il ne faut pas confondre.

pic03

Deuxième interface

R1#configure terminal
R1(config)#interface f0/1
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown

pic003

Routeur 2

Le routeur 2 constitue le deuxième LAN

Première interface

R2#configure terminal
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown

pic04

Deuxième interface

R2#configure terminal
R2(config)#interface f0/1
R2(config-if)#ip address 10.0.0.2 255.0.0.0
R2(config-if)#no shutdown

pic004

Après avoir configuré les adresses IP sur toutes les interfaces des deux routeurs, je peux maintenant passer à la création des routes.

Etape 5 : Le routage.

Comme je l’ai dit brièvement dans la première partie sur la configuration avec Cisco, je veux utiliser le routage statique, parce que le réseau n’est pas vaste.

Pour faire simple, le routage statique se fait en croisant les adresses, d’où le Chiasme.

Les adresses du deuxième routeur seront configurées comme route sur le premier routeur, et celles du premier routeur sur le deuxième.

Routeur 1

R1(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.2

pic05

Routeur 2

R2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1

pic06

Etape 6 : Test

Tu peux voir dans les deux images ci-dessous, les routes créées. La commande pour afficher les routes c’est show ip route.

Routeur 1

pic07

Routeur 2

pic08

Pour finir, je vais faire un PING du PC1 dans le premier LAN vers le PC3 du deuxième LAN pour voir sur les deux réseaux peuvent communiquer.

pic09

Comme tout est bien fait, tu peux remarquer que les deux réseaux peuvent communiquer sans problème aucune.

PS : J’ai failli oublier un point important aussi, pour ajouter une image d’un périphérique (router, switch, etc……)

Il faut cliquer sur le menu Edit ------> Preferences, choisis le périphérique que tu veux ajouter. Avec le routeur par exemple, tu dois cliquer sur IOS Routers ------> News, tu choisi l’image que tu veux ajouter, puis tu cliquer sur Next. Après avoir tout choisi, tu dois validez en quittant.

Conclusion

Ainsi se termine la deuxième et dernière partie sur la configuration des deux réseaux locaux, avec un émulateur cette fois.

Tu as pu voir comment tu peux configurer deux locaux avec GNS3. T’énerves pas si je pas bien structuré comme tu l'aurais voulu, ça viendra avec le temps d'acc ?.

Alors t’en dis quoi, l’article t’a aidé quand-même pas vrai ? alors n’oublies pas à le partager sur tous les réseaux.